Watch API on Postgres occasionally reports namespace modifications as deletions, corrupting the schema cache
Watch API on Postgres occasionally reports namespace modifications as deletions, corrupting the schema cache: a task in MiMo-V2.6-RL-harbor-code: MiMo-V2.6-RL Code (Harbor) (Harbor dataset). We're running SpiceDB in production with Postgres as the datastore, and we have the experimental schema…
The task
We're running SpiceDB in production with Postgres as the datastore, and we have the experimental schema cache enabled (the one that's driven by the Watch API). After running for a while, we start seeing requests fail with errors like:
Part of FineEnvs/MiMo-V2.6-RL-harbor-code.