HF RL Explorer

Task: JSON Top-Level Value Validator

Task: JSON Top-Level Value Validator: a task in Terminal-Lego-15k (Harbor dataset). The JSON specification has evolved over time regarding what constitutes valid top-level JSON text. The original RFC 4627 only allowed objects and arrays as top-level JSON values, while the updated RFC 7159 (and…

The task

The JSON specification has evolved over time regarding what constitutes valid top-level JSON text. The original RFC 4627 only allowed objects and arrays as top-level JSON values, while the updated RFC 7159 (and later RFC 8259) and ECMA-404 allow any JSON value (string, number, boolean, null, object, or array) as a…

Part of PrimeIntellect/Terminal-Lego-15k.