Watch API on Postgres occasionally reports namespace modifications as deletions, corrupting the schema cache
Watch API on Postgres occasionally reports namespace modifications as deletions, corrupting the schema cache: a task in MiMo-V2.6-RL-oss: Agentic RL Environments (MiMo RL release). We're running SpiceDB in production with Postgres as the datastore, and we have the experimental schema cache enabled…
The task
We're running SpiceDB in production with Postgres as the datastore, and we have the experimental schema cache enabled (the one that's driven by the Watch API). After running for a while, we start seeing requests fail with errors like: …even though the namespace is clearly still…
Part of XiaomiMiMo/MiMo-V2.6-RL-oss.